機械音痴な情報系

そしてエンジニアに…。

Ubuntu14.04にCCNXをインストールする

|?| $ sudo apt-get install autoconf libssl-dev libexpat-dev libpcap-dev libecryptfs0 libxml2-utils automake gawk gcc g++ git-core pkg-config libpcre3-dev openjdk-6-jre-lib ||<

実行結果残ってないけど確か、 E: Sub-process /usr/bin/dpkg returned an error code (1) とか E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root? とかちょくちょくエラーが出てた気がするけど気にせずに進む(ぐぐって色々試したけど改善されなかった)。

その後、ccnx-0.8.2のフォルダに移動して、

|bash| $ ./configure $ make $ make test $ make install ||<

で完了。

|bash| $ apt-get install vlc libvlc-dev ||< を実行する。その後terminalでvlcを実行して($ vlc)VLC media playerが立ち上げればOK。

/ccnx-0.8.1/apps/vlcに移動し、その中にあるMakefile.LinuxMakefileという名前に変更する。

その後

|bash| $ make ||< すると、libaccess_ccn_plugin.o、libaccess_ccn_plugin.soという2つのファイルが/vlc内に入っている。

が、makeしてもエラーが出る。

解決方法 まず、Synaptic Package ManagerをSoftware Centerから入手。 その後起動し、検索欄に"libvlccore-dev"と入力しこれをインストール。 もう一度makeするとちゃんと通る。

|bash| $ sudo make install ||<

でおしまい。